Beim Update der Linux 3CX 15.5 SP1 Version auf SP2 oder SP3 kommt es zu folgendem Fehler:  „An error occurred while updating your 3CX Phone System. Please see attached log for details.“

Im angehangenen Logfile:

Paketlisten werden gelesen…
Abhängigkeitsbaum wird aufgebaut….
Statusinformationen werden eingelesen….
Die folgenden zusätzlichen Pakete werden installiert:
bind9-host dnsutils libbind9-90 libdns100 libisc95 libisccc90 libisccfg90
liblwres90 virt-what
Vorgeschlagene Pakete:
rblcheck
Die folgenden NEUEN Pakete werden installiert:
bind9-host dnsutils libbind9-90 libdns100 libisc95 libisccc90 libisccfg90
liblwres90 virt-what
Die folgenden Pakete werden aktualisiert (Upgrade):
3cxpbx
1 aktualisiert, 9 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 1.228 kB von 82,1 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.980 kB Plattenplatz zusätzlich benutzt.
Fehl http://security.debian.org/ jessie/updates/main libisc95 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main libdns100 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main libisccc90 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main libisccfg90 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main libbind9-90 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main liblwres90 amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main bind9-host amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org/ jessie/updates/main dnsutils amd64 1:9.9.5.dfsg-9+deb8u10
404 Not Found [IP: 195.20.242.89 80]
E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/libisc95_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/libdns100_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/libisccc90_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/libisccfg90_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/libbind9-90_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/liblwres90_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/bind9-host_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Fehlschlag beim Holen von http://security.debian.org/pool/updates/main/b/bind9/dnsutils_9.9.5.dfsg-9+deb8u10_amd64.deb 404 Not Found [IP: 195.20.242.89 80]

E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »–fix-missing« probieren?
Rollback to 15.5.3849.1…
Paketlisten werden gelesen…
Abhängigkeitsbaum wird aufgebaut….
Statusinformationen werden eingelesen….
3cxpbx ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Was ist zu tun:

Beim Update können nicht alle Pakete heruntergeladen, daher müsst ihr euch per SSH mit der Maschine verbinden und folgende Befehle ausführen:

sudo echo „deb http://downloads.3cx.com/downloads/3cxpbx/ /“ | sudo tee /etc/apt/sources.list.d/3cxpbx.list

sudo apt-get update

Danach das Update wieder wie gewohnt ausführen und alles sollte funktionieren.

Viel Erfolg!

2018-08-01T10:26:33+02:00

Schnellkontakt:

030 20 84 70 80